1. #1

    Technic Launcher not working

    The launcher worked fine for a few days, then I started getting an error message: Unable to download launcher. Please check your internet connection by opening www.techniclauncher.net in your browser. My internet is working fine. Any ideas on how to fix this or what is going on?

    Thanks!

  2. #2
    froggy911's Avatar
    Join Date
    Dec 2011
    Location
    Somerset
    Posts
    181
    Blog Entries
    1
    Gamer IDs

    PSN ID: honey_badger911 XFIRE ID: froggy911 Steam ID: bjboom Raptr ID: froggy911
    More than likely your Firewall or Anti-Virus is blocking Java and/or Minecraft from the web.
    Try adding Firewall exceptions for Java, Minecraft and Technic Launcher.
    If you need help with this let me know.
    Last edited by froggy911; 30th November 2012 at 16:01.
    If I have helped you today please take a moment to give me a thumbs up
    Avatar by: werepenguin8

  3. #3
    Quote Originally Posted by froggy911 View Post
    More than likely tour Firewall or Anti-Virus is blocking Java and/or Minecraft from the web.
    Try adding Firewall exceptions for Java, Minecraft and Technic Launcher.
    If you need help with this let me know.
    Also one of the more common problems stopping launcher download is in your options, try the "Always use recommended builds" which I have checked all the time now.

  4. #4

  5. #5
    froggy911's Avatar
    Join Date
    Dec 2011
    Location
    Somerset
    Posts
    181
    Blog Entries
    1
    Gamer IDs

    PSN ID: honey_badger911 XFIRE ID: froggy911 Steam ID: bjboom Raptr ID: froggy911
    Have you tried both solutions above?
    If I have helped you today please take a moment to give me a thumbs up
    Avatar by: werepenguin8

  6. #6
    Another thing I would suggest is to re-download the launcher. I don't know what version you are currently running, but the latest version of the launcher is 1.0.3.2
    "As soon as men decide that all means are permitted to fight an evil, then their good becomes indistinguishable from the evil that they set out to destroy."
    --Christopher Dawson

  7. #7
    I have the same problem and I've tried all of these suggestions and none of them worked. Do you guys have any ideas? I set up a Tekkit server 2 days ago. Could there be something that setting up the server changed in how my computer runs the Launcher?

    Nevermind I got It working. there was some Technic related files outside of the .techniclauncher folder that I deleted and the launcher started working again. If anyone has this same problem, try that first. I found them after all of the folders in the roaming folder.
    Last edited by Frozenpeppers; 3rd February 2013 at 02:25.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

» Site Navigation

 > FAQ

» Recent Threads

Yogs-United a Yogcast...
20th September 2014 03:23
by Merco
[Whitelist][Yogscast...
28th September 2014 22:16
Boys vs Girls
8th April 2012 22:42
Hi I'm new!
Yesterday 20:47
Windows 10 announced
Yesterday 10:43
by Goby
New Funny Gaming Channel...
2nd July 2013 06:40
by faw601
Re-Introduction, Hello...
Yesterday 22:27
by Paul163
Power of Elements RP...
20th January 2013 15:40
Youtube Group looking...
22nd September 2014 14:37
StarForge and loads of...
30th September 2014 18:58
by Webmetz

Log in

Log in